summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-14 22:53:03 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:32:50 +0200
commit6e8dd0b5daff210beb7ab78057f40900bccf956f (patch)
tree7f2e8bab94b068c4ca03978af826cbbe636f12a3
parent44c95fa650b1fd259bfd6b7d5961b2e0391c77db (diff)
downloadguix-patches-6e8dd0b5daff210beb7ab78057f40900bccf956f.tar
guix-patches-6e8dd0b5daff210beb7ab78057f40900bccf956f.tar.gz
gnu: utf8proc: Update to 2.5.0.
* gnu/packages/textutils.scm (utf8proc): Update to 2.5.0. [native-inputs]: Update test data to Unicode 13.
-rw-r--r--gnu/packages/textutils.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c2184de46b..ddafd4cc34 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -140,7 +140,7 @@ libenca and several charset conversion libraries and tools.")
(define-public utf8proc
(package
(name "utf8proc")
- (version "2.4.0")
+ (version "2.5.0")
(source
(origin
(method git-fetch)
@@ -149,23 +149,23 @@ libenca and several charset conversion libraries and tools.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1i42hqwc8znqii9brangwkxk5cyc2lk95ip405fg88zr7z2ncr34"))))
+ (base32 "1xlkazhdnja4lksn5c9nf4bln5gjqa35a8gwlam5r0728w0h83qq"))))
(build-system gnu-build-system)
(native-inputs ;test data that is otherwise downloaded with curl
`(("NormalizationTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/13.0.0/ucd/"
"NormalizationTest.txt"))
(sha256
- (base32 "0hb97k9xv1lr847hwz0719ksqy39s47xw6k01dgs1368jdibvawc"))))
+ (base32 "07g0ya4f6zfzvpp24ccxkb2yq568kh83gls85rjl950nv5fya3nn"))))
("GraphemeBreakTest.txt"
,(origin
(method url-fetch)
- (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
+ (uri (string-append "https://www.unicode.org/Public/13.0.0/ucd/"
"auxiliary/GraphemeBreakTest.txt"))
(sha256
- (base32 "0qc90ppmrwfn3y9cdn8jcjrn7qpdf0fhxkwh945yp4rvh37mbgcm"))))
+ (base32 "07f8rrvcsq4pibdz6zxggxy8w7zjjqyw2ggclqlhalyv45yv7prj"))))
;; For tests.
("perl" ,perl)))