summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-21 03:16:55 +0200
committerMarius Bakke <marius@gnu.org>2022-06-21 17:30:44 +0200
commitc3f6049a410d6e1c8703fb6750ec6fa9646138cd (patch)
treee004fe38df7a700346c4a71cf51fd08ea5125391
parentacdd0c282f4fd800891149915f6b4928aa991fba (diff)
downloadguix-patches-c3f6049a410d6e1c8703fb6750ec6fa9646138cd.tar
guix-patches-c3f6049a410d6e1c8703fb6750ec6fa9646138cd.tar.gz
gnu: python-nose2: Update to 0.11.0.
* gnu/packages/check.scm (python-nose2): Update to 0.11.0. [arguments]: Add #:phases. Remove #:tests?. [propagated-inputs]: Remove PYTHON-COV-CORE and PYTHON-PYTEST-COV. [native-inputs]: Add PYTHON-COVERAGE.
-rw-r--r--gnu/packages/check.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5c8b547c0d..d67149d85a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -892,18 +892,28 @@ available via the @code{unittest.mock} module.")
(define-public python-nose2
(package
(name "python-nose2")
- (version "0.9.2")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nose2" version))
(sha256
(base32
- "0pmbb6nk31yhgh4zkcblzxsznml7f7pf5q1ihgrwvbxv4mwzfql7"))))
+ "1scxwvwbgfdj41acma41xzdhcfdwjj9irj6sfifdbyf9dryqs83d"))))
(build-system python-build-system)
- (arguments `(#:tests? #f)) ; 'module' object has no attribute 'collector'
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Tests require nose2 itself.
+ (setenv "PYTHONPATH" (getcwd))
+ (invoke (string-append #$output "/bin/nose2") "-v")))))))
+ (native-inputs
+ (list python-coverage))
(propagated-inputs
- (list python-cov-core python-pytest-cov python-six))
+ (list python-six))
(home-page "https://github.com/nose-devs/nose2")
(synopsis "Next generation of nicer testing for Python")
(description