summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-27 15:01:30 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-27 15:01:30 +0100
commit785db4d877959c0b948859d19dff22384924fae4 (patch)
treedc0f5d20d3b37311ea77f475c4316177cc6e757a
parent0b5aa854a0387d10c48488f408ffa21367ea48ac (diff)
downloadguix-patches-785db4d877959c0b948859d19dff22384924fae4.tar
guix-patches-785db4d877959c0b948859d19dff22384924fae4.tar.gz
glib: Patch around prlimit(2) failure.
* gnu/packages/glib.scm (glib)[source]: Switch to mirror://gnome. [inputs]: Add `patch/tests-prlimit'. [arguments]: Add it. * gnu/packages/patches/glib-tests-prlimit.patch: New file. * Makefile.am (dist_patch_DATA): Add it.
-rw-r--r--Makefile.am5
-rw-r--r--gnu/packages/glib.scm9
-rw-r--r--gnu/packages/patches/glib-tests-prlimit.patch14
3 files changed, 23 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index c785014451..706c00e8b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -201,6 +201,7 @@ dist_patch_DATA = \
gnu/packages/patches/gettext-gets-undeclared.patch \
gnu/packages/patches/glib-tests-desktop.patch \
gnu/packages/patches/glib-tests-homedir.patch \
+ gnu/packages/patches/glib-tests-prlimit.patch \
gnu/packages/patches/glib-tests-timezone.patch \
gnu/packages/patches/glibc-bootstrap-system.patch \
gnu/packages/patches/glibc-no-ld-so-cache.patch \
@@ -209,7 +210,7 @@ dist_patch_DATA = \
gnu/packages/patches/guile-default-utf8.patch \
gnu/packages/patches/guile-linux-syscalls.patch \
gnu/packages/patches/guile-relocatable.patch \
- gnu/packages/patches/libapr-skip-getservbyname-test.patch \
+ gnu/packages/patches/libapr-skip-getservbyname-test.patch \
gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/libtool-skip-tests.patch \
gnu/packages/patches/lsh-guile-compat.patch \
@@ -226,7 +227,7 @@ dist_patch_DATA = \
gnu/packages/patches/readline-link-ncurses.patch \
gnu/packages/patches/shishi-gets-undeclared.patch \
gnu/packages/patches/tar-gets-undeclared.patch \
- gnu/packages/patches/tcsh-fix-autotest.patch \
+ gnu/packages/patches/tcsh-fix-autotest.patch \
gnu/packages/patches/teckit-cstdio.patch \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/w3m-fix-compile.patch
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 72e8d7ed2b..fdcc9bdc31 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -76,7 +76,7 @@ shared NFS home directories.")
(version "2.34.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://ftp.gnome.org/pub/gnome/sources/"
+ (uri (string-append "mirror://gnome/sources/"
name "/2.34/"
name "-" version ".tar.xz"))
(sha256
@@ -99,11 +99,14 @@ shared NFS home directories.")
("patch/tests-homedir"
,(search-patch "glib-tests-homedir.patch"))
("patch/tests-desktop"
- ,(search-patch "glib-tests-desktop.patch"))))
+ ,(search-patch "glib-tests-desktop.patch"))
+ ("patch/tests-prlimit"
+ ,(search-patch "glib-tests-prlimit.patch"))))
(arguments
'(#:patches (list (assoc-ref %build-inputs "patch/tests-tzdata")
(assoc-ref %build-inputs "patch/tests-homedir")
- (assoc-ref %build-inputs "patch/tests-desktop"))
+ (assoc-ref %build-inputs "patch/tests-desktop")
+ (assoc-ref %build-inputs "patch/tests-prlimit"))
#:phases (alist-cons-before
'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
diff --git a/gnu/packages/patches/glib-tests-prlimit.patch b/gnu/packages/patches/glib-tests-prlimit.patch
new file mode 100644
index 0000000000..f2b2a61bee
--- /dev/null
+++ b/gnu/packages/patches/glib-tests-prlimit.patch
@@ -0,0 +1,14 @@
+prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64 as found on
+hydra.gnu.org, and strace(1) doesn't recognize it.
+
+--- glib-2.34.3/glib/tests/thread.c 2012-11-20 15:27:12.000000000 +0100
++++ glib-2.34.3/glib/tests/thread.c 2013-03-27 14:48:31.000000000 +0100
+@@ -130,7 +130,7 @@ test_thread3 (void)
+ static void
+ test_thread4 (void)
+ {
+-#ifdef HAVE_PRLIMIT
++#if 0
+ struct rlimit ol, nl;
+ GThread *thread;
+ GError *error;