summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-07 15:39:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-07 15:39:18 +0100
commit8dcf062f288fefd024b13f967a3de11606e037f5 (patch)
tree51990c45fec6d5d966825ad7fa841b0fa71057c4
parenta98fe1d46e3d6e6aa03f7cbd9b4afc74796bac00 (diff)
downloadguix-patches-8dcf062f288fefd024b13f967a3de11606e037f5.tar
guix-patches-8dcf062f288fefd024b13f967a3de11606e037f5.tar.gz
gnu: python-ndg-httpsclient: Add missing input.
* gnu/packages/python-web.scm (python-ndg-httpsclient)[propagated-inputs]: Add python-pyasn1.
-rw-r--r--gnu/packages/python-web.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f9af939781..ad7e9dd94d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2399,7 +2399,8 @@ deprecation warnings to be issued when a variable is used.")
'(;; The tests appear to require networking.
#:tests? #f))
(propagated-inputs
- `(("python-pyopenssl" ,python-pyopenssl)))
+ `(("python-pyasn1" ,python-pyasn1)
+ ("python-pyopenssl" ,python-pyopenssl)))
(synopsis "HTTPS support for Python's httplib and urllib2")
(description "This is a HTTPS client implementation for httplib and urllib2
based on PyOpenSSL. PyOpenSSL provides a more fully-featured SSL implementation