summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-21 03:32:10 +0200
committerMarius Bakke <marius@gnu.org>2022-06-21 17:30:44 +0200
commit779853e926bdb075dfadbf7dbc1a0e6bdcb93d66 (patch)
tree0160acf6b9408bd2aad91efee0bf28139152130d
parentc3f6049a410d6e1c8703fb6750ec6fa9646138cd (diff)
downloadguix-patches-779853e926bdb075dfadbf7dbc1a0e6bdcb93d66.tar
guix-patches-779853e926bdb075dfadbf7dbc1a0e6bdcb93d66.tar.gz
gnu: python-pika: Update to 1.2.1.
* gnu/packages/python-xyz.scm (python-pika): Update to 1.2.1. [arguments]: Adjust tests for nose2. Respect #:tests? keyword. [native-inputs]: Remove PYTHON-NOSE; add PYTHON-NOSE2.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e6fe74323..11c50a762b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16120,7 +16120,7 @@ focus on event-based network programming and multiprotocol integration.")
(define-public python-pika
(package
(name "python-pika")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method git-fetch)
@@ -16130,27 +16130,29 @@ focus on event-based network programming and multiprotocol integration.")
(file-name (git-file-name name version))
(sha256
(base32
- "0cm45xydk2jigydwszwik89qlbk6l3l18sxhzppzqmxw2rdkm22s"))))
+ "0sqj3bg6jwign8vwvn337fbwy69sm684ns1vh5kbfnskq4him9i2"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-live-tests
+ (add-after 'unpack 'disable-live-tests
(lambda _
;; Disable tests that require RabbitMQ, which is not
;; yet available in Guix.
- (substitute* "setup.cfg"
- (("tests/unit,tests/acceptance")
- "tests/unit"))
+ (substitute* "nose2.cfg"
+ (("tests=tests/unit,tests/acceptance")
+ "start-dir=tests/unit"))
(with-directory-excursion "tests"
(for-each delete-file
'("unit/base_connection_tests.py"
"unit/threaded_test_wrapper_test.py")))))
(replace 'check
- (lambda _
- (invoke "nosetests"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "PYTHONPATH" (getcwd))
+ (invoke "nose2" "-v")))))))
(native-inputs
(list python-mock
- python-nose
+ python-nose2
;; These are optional at runtime, and provided here for tests.
python-gevent
python-tornado