summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 13:41:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 13:43:12 +0200
commit755733a3fee60097735ac85a388b582b30e68b88 (patch)
tree01a4007f6d8c03bc62ea2624356dc477a2355246
parentc261a7b39ab8f5d46299205e5421cb46aae5634e (diff)
downloadguix-patches-755733a3fee60097735ac85a388b582b30e68b88.tar
guix-patches-755733a3fee60097735ac85a388b582b30e68b88.tar.gz
gnu: Add r-fourcseq.
* gnu/packages/cran.scm (r-fourcseq): New variable. Co-authored-by: Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
-rw-r--r--gnu/packages/cran.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ac246bd123..e81d11e6e5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22230,3 +22230,47 @@ inferring an appropriate positioning method.")
Try a demo of the LSD by running @code{demotour()}.")
;; Either version
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-fourcseq
+ (package
+ (name "r-fourcseq")
+ (version "1.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "FourCSeq" version))
+ (sha256
+ (base32 "0lhcjw2hmmdafq52c5fvpm1crnzynbslamzh7r6ygifmzaz2pa8x"))))
+ (properties `((upstream-name . "FourCSeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biostrings" ,r-biostrings)
+ ("r-deseq2" ,r-deseq2)
+ ("r-fda" ,r-fda)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggbio" ,r-ggbio)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gtools" ,r-gtools)
+ ("r-lsd" ,r-lsd)
+ ("r-matrix" ,r-matrix)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://bioconductor.org/packages/release/bioc/html/FourCSeq.html")
+ (synopsis "Analysis of multiplexed 4C sequencing data")
+ (description
+ "This package is an R package dedicated to the analysis of (multiplexed)
+4C sequencing data. @code{r-fourcseq} provides a pipeline to detect specific
+interactions between DNA elements and identify differential interactions
+between conditions. The statistical analysis in R starts with individual bam
+files for each sample as inputs. To obtain these files, the package contains
+a Python script to demultiplex libraries and trim off primer sequences. With
+a standard alignment software the required bam files can be then be
+generated.")
+ (license license:gpl3+)))