summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 17:12:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 17:12:58 +0300
commit6562a3883f4a6f23e98f4800043397918a1fbafd (patch)
tree225c0f81eae22af6d3d9da25cca4752342348b42
parent59bcda1e8cae77ce3947ff2a6051e77440d36aed (diff)
downloadguix-patches-6562a3883f4a6f23e98f4800043397918a1fbafd.tar
guix-patches-6562a3883f4a6f23e98f4800043397918a1fbafd.tar.gz
gnu: pidentd: Don't use unstable tarball.
* gnu/packages/networking.scm (pidentd)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6113061e6f..a847af5049 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2037,13 +2037,14 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
(version "3.0.19")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ptrrkssn/pidentd/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ptrrkssn/pidentd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0y3kd1bkydqkpc1qdff24yswysamsqivvadjy0468qri5730izgc"))))
+ "1k4rr0b4ygxssbnsykzjvz4hjhazzz4j5arlilyc1iq7b1wzsk7i"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; No tests are included
@@ -2052,7 +2053,7 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
(home-page "https://www.lysator.liu.se/~pen/pidentd/")
(synopsis "Small Ident Daemon")
(description
- "@dfn{Pidentd} (Peter's Ident Daemon) is a identd, which implements a
+ "@dfn{Pidentd} (Peter's Ident Daemon) is an identd, which implements a
identification server. Pidentd looks up specific TCP/IP connections and
returns the user name and other information about the connection.")
(license license:public-domain)))