summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2022-06-21 00:41:29 +0300
committerChristopher Baines <mail@cbaines.net>2022-06-21 12:35:15 +0100
commit55567ca43444544d033602834181ce042acd9a19 (patch)
tree257e7df51701a4de5fe38bd733eabe445913c8f2
parent76baecf58f2322ceec8a1660a58611b5ce4b08e9 (diff)
downloadguix-patches-55567ca43444544d033602834181ce042acd9a19.tar
guix-patches-55567ca43444544d033602834181ce042acd9a19.tar.gz
gnu: networking: Add arp-scan
* gnu/packages/networking.scm (arp-scan): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/networking.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 065a190321..b308b7e595 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Simon South <simon@simonsouth.net>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -184,6 +185,33 @@ oriented, reliable transport protocol with direct support for multihoming that
runs on top of IP or UDP, and supports both v4 and v6 versions.")
(license license:bsd-3)))
+(define-public arp-scan
+ (package
+ (name "arp-scan")
+ (version "1.9.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/royhills/arp-scan/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mf7a4f9vzvnkiavc87aqyciswggsb4fpy7j05jxnvjyyxv3l7gp"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libpcap))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (propagated-inputs
+ (list perl-libwww))
+ (home-page "https://github.com/royhills/arp-scan")
+ (synopsis "Discover and fingerprint IP hosts on the local network using ARP")
+ (description "Arp-scan is a tool that uses ARP to discover and fingerprint
+IP hosts on the local network.")
+ (license license:gpl3+)))
+
(define-public axel
(package
(name "axel")