summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2018-07-20 23:33:35 +1000
committerMarius Bakke <mbakke@fastmail.com>2018-07-22 16:44:53 +0200
commit4febfdd0f33d1511bede56791f1362e04708aad9 (patch)
tree1c123ce2f13fa052723b995bd81b678a8d0130bd
parent706a6ff1544f2fc4baa1d4d2e1cd093a41411906 (diff)
downloadguix-patches-4febfdd0f33d1511bede56791f1362e04708aad9.tar
guix-patches-4febfdd0f33d1511bede56791f1362e04708aad9.tar.gz
gnu: ffmpegthumbnailer: New variable.
* gnu/packages/video.scm (ffmpegthumbnailer): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/video.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7bf4e43791..8f4c60c424 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -817,6 +818,35 @@ audio/video codec library.")
flag))
,flags))))))
+(define-public ffmpegthumbnailer
+ (package
+ (name "ffmpegthumbnailer")
+ (version "2.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dirkvdb/"
+ name "/archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "13qs4iwd4l3iiim30s5051n80z0vgsnikym8vsn321cnm9algiwb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("gvfs" ,gvfs)))
+ (arguments
+ `(#:configure-flags (list "-DENABLE_GIO=ON" "-DENABLE_THUMBNAILER=ON")))
+ (home-page "https://github.com/dirkvdb/ffmpegthumbnailer")
+ (synopsis "Create thumbnails from video files")
+ (description "FFmpegthumbnailer is a lightweight video thumbnailer that
+can be used by file managers to create thumbnails for your video files. The
+thumbnailer uses ffmpeg to decode frames from the video files, so supported
+videoformats depend on the configuration flags of ffmpeg.")
+ (license license:gpl2+)))
+
(define-public vlc
(package
(name "vlc")