summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-13 18:58:28 +0200
committerMarius Bakke <marius@gnu.org>2020-06-13 23:29:21 +0200
commit41cb238281886396f77e4cf0be8ddf5b4419d688 (patch)
tree38e632f79a721dbf6202a1933de424dd600a6c8e
parentdd61cd85f1f675d7f7503e7412f3021af6d2cb57 (diff)
downloadguix-patches-41cb238281886396f77e4cf0be8ddf5b4419d688.tar
guix-patches-41cb238281886396f77e4cf0be8ddf5b4419d688.tar.gz
gnu: libnet: Update to 1.2.
* gnu/packages/networking.scm (libnet): Update to 1.2. [source]: Switch to URL-FETCH. [arguments]: Remove chdir phase. [native-inputs]: Remove AUTOCONF, AUTOMAKE, and LIBTOOL. Add PERL.
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index feba70878c..bb4b35d922 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2121,32 +2121,27 @@ interface and a programmable text output for scripting.")
(define-public libnet
(package
(name "libnet")
- (version "1.2-rc3")
+ (version "1.2")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sam-github/libnet")
- (commit (string-append "libnet-" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://github.com/libnet/libnet/releases/download"
+ "/v" version "/libnet-" version ".tar.gz"))
(sha256
(base32
- "0cy8w4g5rv963v4p6iq3333kxgdddx2lywp70xf62553a25xhhs4"))))
+ "19ys9vxk6fg70yzzdxsphfr0rwzgxxhr9b3ykhpg7rfray0qd96a"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "libnet") #t))
(add-before 'build 'build-doc
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "-C" "doc" "doc"
make-flags))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("doxygen" ,doxygen)))
+ `(;; To build the documentation, Doxygen and Perl is required.
+ ("doxygen" ,doxygen)
+ ("perl" ,perl)))
(home-page "https://sourceforge.net/projects/libnet-dev/")
(synopsis "Framework for low-level network packet construction")
(description