summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:27:31 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:31 -0600
commitccb8829847cbb41fae0d8f13c9783b0a844b2b45 (patch)
tree549c1d674edd4ebd76626bd7ad932114a85dce64
parent15cd054296a706ed9713c4d09ad06f320cb9efac (diff)
downloadguix-patches-ccb8829847cbb41fae0d8f13c9783b0a844b2b45.tar
guix-patches-ccb8829847cbb41fae0d8f13c9783b0a844b2b45.tar.gz
gnu: Add LibDOM.
* gnu/packages/web.scm (libdom): New variable.
-rw-r--r--gnu/packages/web.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1a44029c0e..b60877bef1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3877,6 +3877,42 @@ developed as part of the Netsurf project.")
written in C. It is developed as part of the NetSurf project.")
(license l:expat)))
+(define-public libdom
+ (package
+ (name "libdom")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+ name "-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0qy7c8b229aiamyqqjgp6m1jlzc3fpl8s9dk33kxzkj70na8l7hv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("netsurf-buildsystem" ,netsurf-buildsystem)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl) ;for test harness
+ ("perl-libxml" ,perl-libxml)
+ ("perl-switch" ,perl-switch)
+ ("perl-xml-xpath" ,perl-xml-xpath)))
+ (inputs
+ `(("libparserutils" ,libparserutils)
+ ("libwapcaplet" ,libwapcaplet)))
+ (propagated-inputs
+ `(("expat" ,expat) ;needed for headers and linking
+ ("hubbub" ,hubbub))) ;for libdom.pc
+ (arguments
+ `(#:tests? #f ;TODO: re-enable. tests take a looong time.
+ ,@netsurf-buildsystem-arguments))
+ (home-page "http://www.netsurf-browser.org/projects/libdom/")
+ (synopsis "Implementation of the W3C DOM")
+ (description
+ "LibDOM is an implementation of the W3C DOM, written in C. It is
+developed as part of the NetSurf project.")
+ (license l:expat)))
+
(define-public netsurf
(package
(name "netsurf")