summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:29:43 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:32 -0600
commit6fae2256e95a385a851c8ea8a523ef47d3b91fa3 (patch)
treefe50503f8c7659b11ce11218344938a9e9f62690
parentccb8829847cbb41fae0d8f13c9783b0a844b2b45 (diff)
downloadguix-patches-6fae2256e95a385a851c8ea8a523ef47d3b91fa3.tar
guix-patches-6fae2256e95a385a851c8ea8a523ef47d3b91fa3.tar.gz
gnu: Add libsvgtiny.
* gnu/packages/web.scm (libsvgtiny): New variable.
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b60877bef1..654bbf269f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3913,6 +3913,37 @@ written in C. It is developed as part of the NetSurf project.")
developed as part of the NetSurf project.")
(license l:expat)))
+(define-public libsvgtiny
+ (package
+ (name "libsvgtiny")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.netsurf-browser.org/libs/releases/"
+ name "-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0w5hab9x1saz4lq2s9w47x1r64fbzcsl5bvdjph9c9dq68qv3f8a"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("netsurf-buildsystem" ,netsurf-buildsystem)
+ ("pkg-config" ,pkg-config)
+ ("gperf" ,gperf)))
+ (inputs
+ `(("libwapcaplet" ,libwapcaplet)))
+ (propagated-inputs
+ `(("libdom" ,libdom))) ;for libsvgtiny.pc
+ (arguments netsurf-buildsystem-arguments)
+ (home-page "http://www.netsurf-browser.org/projects/libsvgtiny/")
+ (synopsis "Library for parsing SVG files")
+ (description
+ "Libsvgtiny takes some SVG as input and returns a list of paths and texts
+which can be rendered easily, as defined in
+@url{http://www.w3.org/TR/SVGMobile/}. It is developed as part of the NetSurf
+project.")
+ (license l:expat)))
+
(define-public netsurf
(package
(name "netsurf")