summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-05-01 11:55:20 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-02 09:27:17 +0200
commitf3f8d159c3e4b30861bbd3082bc422bb80b5b823 (patch)
tree0a43ff98c7cbe2e7722e2d219d722f8b4ef763dd
parent60c9e80444421c412ae3d0e7b4b224ef0e32947f (diff)
downloadguix-patches-f3f8d159c3e4b30861bbd3082bc422bb80b5b823.tar
guix-patches-f3f8d159c3e4b30861bbd3082bc422bb80b5b823.tar.gz
gnu: Add python-oauth2client.
* gnu/packages/python.scm (python-oauth2client): New variable.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e1dfd00547..7fbf44fe97 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14054,3 +14054,29 @@ exception message with a traceback that points to the culprit.")
(define-public python2-fudge
(package-with-python2 python-fudge))
+
+(define-public python-oauth2client
+ (package
+ (name "python-oauth2client")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "oauth2client" version))
+ (sha256
+ (base32
+ "1irqqap2zibysf8dba8sklfqikia579srd0phm5n754ni0h59gl0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-httplib2" ,python-httplib2)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyasn1-modules" ,python-pyasn1-modules)
+ ("python-rsa" ,python-rsa)
+ ("python-six" ,python-six)))
+ (home-page "http://github.com/google/oauth2client/")
+ (synopsis "OAuth 2.0 client library")
+ (description "@code{python-oauth2client} provides an OAuth 2.0 client
+library for Python")
+ (license license:asl2.0)))