summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 22:55:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:14 -0400
commitce6d29988816bb9e0c5f8da775405527f22f2e63 (patch)
tree28dc85b23d098b9b5b9d50802bec821350cca0a1
parentca01fd0084d0d76670209ea9bac3df18f397488a (diff)
downloadguix-patches-ce6d29988816bb9e0c5f8da775405527f22f2e63.tar
guix-patches-ce6d29988816bb9e0c5f8da775405527f22f2e63.tar.gz
gnu: Remove python2-cloudpickle.
* gnu/packages/python-xyz.scm (python2-cloudpickle): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 081a455d04..ed0c6d22fb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23754,30 +23754,8 @@ supported by the default pickle module from the Python standard library. It
is especially useful for cluster computing where Python expressions are
shipped over the network to execute on remote hosts, possibly close to the
data.")
- (properties `((python2-variant . ,(delay python2-cloudpickle))))
(license license:bsd-3)))
-(define-public python2-cloudpickle
- (let ((base (package-with-python2 (strip-python2-variant python-cloudpickle))))
- (package/inherit base
- (version "1.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "cloudpickle" version))
- (sha256
- (base32
- "0lx7gy9clp427qwcm7b23zdsldpr03gy3vxxhyi8fpbhwz859brq"))))
- (native-inputs
- `(;; For tests.
- ("python-mock" ,python2-mock)
- ("python-psutil" ,python2-psutil)
- ("python-pytest" ,python2-pytest)
- ("python-tornado" ,python2-tornado)))
- (propagated-inputs
- `(("python-futures" ,python2-futures)
- ,@(package-propagated-inputs base))))))
-
(define-public python-locket
(package
(name "python-locket")