summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Prat <vprat@deeplinks.com>2022-04-29 09:43:35 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-06 10:32:06 +0200
commit9e630a362d8d280800cc96c9420ff09f119228b7 (patch)
treeea6c1104eb633cc9041aa53bebf58375a80a5c60
parent7727757a73ad6dad7db724a2170343cb68145e67 (diff)
downloadguix-patches-9e630a362d8d280800cc96c9420ff09f119228b7.tar
guix-patches-9e630a362d8d280800cc96c9420ff09f119228b7.tar.gz
gnu: Add python-arpeggio.
* gnu/packages/python-xyz.scm (python-arpeggio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 804cffced4..cf3e201b1a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29675,6 +29675,35 @@ versions of MkDocs-powered docs to a Git branch. It is suitable for deploying
to Github via gh-pages.")
(license license:bsd-3)))
+(define-public python-arpeggio
+ (package
+ (name "python-arpeggio")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Arpeggio" version))
+ (sha256
+ (base32
+ "0ggdsck1wpladd5bh9drhkmm86bblgk2wagrhn3sdf4v04wkic6n"))))
+ (build-system python-build-system)
+ (native-inputs (list python-coverage
+ python-coveralls
+ python-flake8
+ python-mike
+ python-mkdocs
+ python-pytest
+ python-pytest-runner
+ python-twine
+ python-wheel))
+ (home-page "https://github.com/textX/Arpeggio")
+ (synopsis "Packrat parser interpreter for Python")
+ (description
+ "This Python library provides a recursive descent parser with backtracking
+and memoization (a.k.a. packrat parser). Arpeggio grammars are based on PEG
+formalism. Arpeggio's main use is a foundation for a toolchain for DSL
+development but it can be used for all sorts of general purpose parsing.")
+ (license license:expat)))
+
(define-public python-flatten-json
(package
(name "python-flatten-json")