summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-19 23:06:51 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-19 23:14:57 +0200
commit73761d8049f483e6685c2c736872d0366e03238a (patch)
tree0ceafbed9b756873fb1ae445fbfd90c437f0c976
parentdbe221a89ac369c1d0f7679acb20544e08357413 (diff)
downloadguix-patches-73761d8049f483e6685c2c736872d0366e03238a.tar
guix-patches-73761d8049f483e6685c2c736872d0366e03238a.tar.gz
gnu: lxd: Remove input labels.
* gnu/packages/virtualization.scm (lxd)[arguments]: In 'install' phase, refer to "bash-minimal" instead of "bash". [inputs]: Remove labels.
-rw-r--r--gnu/packages/virtualization.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 015c291ec3..4cb83b4d85 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2017, 2020-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017, 2018. 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -1213,13 +1213,15 @@ It started as a side project of LXC but can be used by any run-time.")
(wrap-program (string-append bin-dir "lxd")
`("PATH" ":" prefix
,(fold (lambda (input paths)
+ ;; TODO: Use 'search-input-directory' rather
+ ;; than look up inputs by name.
(let* ((in (assoc-ref inputs input))
(bin (string-append in "/bin"))
(sbin (string-append in "/sbin")))
(append (filter file-exists?
(list bin sbin)) paths)))
'()
- '("bash" "acl" "rsync" "tar" "xz" "btrfs-progs"
+ '("bash-minimal" "acl" "rsync" "tar" "xz" "btrfs-progs"
"gzip" "dnsmasq" "squashfs-tools" "iproute2"
"criu" "iptables" "attr"))))
;; Remove unwanted binaries.
@@ -1240,25 +1242,25 @@ It started as a side project of LXC but can be used by any run-time.")
;; ("go-golang-org-x-lint" ,go-golang-org-x-lint)
pkg-config))
(inputs
- `(("acl" ,acl)
- ("eudev" ,eudev)
- ("libdqlite" ,libdqlite)
- ("libraft" ,libraft)
- ("libcap" ,libcap)
- ("lxc" ,lxc)
- ;; Run-time dependencies.
- ("attr" ,attr)
- ("bash" ,bash-minimal)
- ("rsync" ,rsync)
- ("tar" ,tar)
- ("xz" ,xz)
- ("btrfs-progs" ,btrfs-progs)
- ("gzip" ,gzip)
- ("dnsmasq" ,dnsmasq)
- ("squashfs-tools" ,squashfs-tools)
- ("iproute2" ,iproute)
- ("criu" ,criu)
- ("iptables" ,iptables)))
+ (list acl
+ eudev
+ libdqlite
+ libraft
+ libcap
+ lxc
+ ;; Run-time dependencies.
+ attr
+ bash-minimal
+ rsync
+ tar
+ xz
+ btrfs-progs
+ gzip
+ dnsmasq
+ squashfs-tools
+ iproute
+ criu
+ iptables))
(synopsis "Daemon based on liblxc offering a REST API to manage containers")
(home-page "https://linuxcontainers.org/lxd/")
(description "LXD is a next generation system container manager. It