summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 16:37:27 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:15 +0100
commit4d10384f6435f657cd251cdca8d279b18b843ec2 (patch)
tree9c2f56be975ac9254667480aa53e0c8064f95284
parente5f1945e58739394a48d4a8a610c11a3c9d0a3a8 (diff)
downloadguix-patches-4d10384f6435f657cd251cdca8d279b18b843ec2.tar
guix-patches-4d10384f6435f657cd251cdca8d279b18b843ec2.tar.gz
gnu: python-platformdirs: Update to 2.4.1.
* gnu/packages/python-xyz.scm (python-platformdirs): Update to 2.4.1. [arguments]: Override check phase. [native-inputs]: Add PYTHON-SETUPTOOLS-SCM. Remove PYTHON-PYTEST-COV.
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2d14482bb0..2c332de983 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27810,17 +27810,22 @@ compatible with a wide range of versions of the Stripe API.")
(define-public python-platformdirs
(package
(name "python-platformdirs")
- (version "2.2.0")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "platformdirs" version))
(sha256
- (base32 "07hq5qrp7pqj63iczg01wbf5ii6f0ncd0dq5mzkdhsslmg9slbb3"))))
+ (base32 "1njz0h4iky8iglrb85cd07hpa3lp1a2dfr934dj65hxwzvfk61j4"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
(native-inputs
- (list python-appdirs python-pytest python-pytest-cov
- python-pytest-mock))
+ (list python-appdirs python-pytest python-pytest-mock
+ python-setuptools-scm))
(home-page "https://github.com/platformdirs/platformdirs")
(synopsis "Determine the appropriate platform-specific directories")
(description "When writing applications, finding the right location to