summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-05 12:37:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-06 10:15:04 +0200
commit43992cdbea4d264a8e2aea1905eff98006709fbc (patch)
treeefb663e00d8739d7e4e8eaa6993a0bb27ce32c1a
parentb95e3dc17cc8f4ba4f7796a12c34837dd4af164b (diff)
downloadguix-patches-43992cdbea4d264a8e2aea1905eff98006709fbc.tar
guix-patches-43992cdbea4d264a8e2aea1905eff98006709fbc.tar.gz
gnu: python-anyio: Update to 3.5.0.
* gnu/packages/python-xyz.scm (python-anyio): Update to 3.5.0. [arguments]: Remove phase 'fix-compatibility; disable one more test. [propagated-inputs]: Add python-contextvars and python-dataclasses. [native-inputs]: Add python-contextlib2 and python-trio; remove python-iniconfig.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a37dc5e9e2..aa74063ace 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24736,25 +24736,18 @@ standard error channel (stderr) in your program.")
(define-public python-anyio
(package
(name "python-anyio")
- (version "3.3.0")
+ (version "3.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "anyio" version))
(sha256
(base32
- "0x03hsprdrs86wjjkj96zm2jswy3a5bgyrknyi58pzz5hdsscmxf"))))
+ "19m58805wir4i2s45dd5ynwlzb7ky1218isbir53gpqzzgigzbm0"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-compatibility
- (lambda _
- (substitute* "tests/test_taskgroups.py"
- (("import pytest")
- "import pytest\nimport _pytest\nfrom _pytest import logging")
- (("pytest.LogCaptureFixture")
- "_pytest.logging.LogCaptureFixture"))))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
@@ -24791,18 +24784,24 @@ standard error channel (stderr) in your program.")
" and not test_send_eof"
" and not test_send_large_buffer"
" and not test_send_receive"
- " and not test_socket_options"))))))))
+ " and not test_socket_options"
+ " and not test_unretrieved_future_exception_server_crash"))))))))
(propagated-inputs
- (list python-idna python-sniffio python-typing-extensions))
+ (list python-contextvars
+ python-dataclasses
+ python-idna
+ python-sniffio
+ python-typing-extensions))
(native-inputs
- (list python-coverage
+ (list python-contextlib2
+ python-coverage
python-hypothesis
- python-iniconfig
python-mock
python-pytest-6
python-pytest-mock
python-pytest-trio
python-setuptools-scm
+ python-trio
python-trustme
python-uvloop))
(home-page "https://github.com/agronholm/anyio")