summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-06 11:23:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-06 13:02:59 +0200
commit221bf543e8e92230424d7d3ca7f1c61c33b536f9 (patch)
treee3d5cbae6473a71048c0d0e73110962d034d765d
parent0d73287d9735f607b1f1bb3b1230553c7b4c7972 (diff)
downloadguix-patches-221bf543e8e92230424d7d3ca7f1c61c33b536f9.tar
guix-patches-221bf543e8e92230424d7d3ca7f1c61c33b536f9.tar.gz
gnu: Add python-xyzservices.
* gnu/packages/python-xyz.scm (python-xyzservices): New variable.
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cde610455f..6f450f6c50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24429,6 +24429,33 @@ containing a given point, and quadkey conversion functions
translating between quadkey and tile coordinates.")
(license license:bsd-3)))
+(define-public python-xyzservices
+ (package
+ (name "python-xyzservices")
+ (version "2022.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xyzservices" version))
+ (sha256
+ (base32 "1paxv4i0dws85md7csv7pf80jl3xh792mx8rxnsrk61ks3ivbsyg"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs
+ (list python-pytest python-mercantile python-requests))
+ (home-page "https://github.com/geopandas/xyzservices")
+ (synopsis "Source of XYZ tiles providers")
+ (description "@code{xyzservices} is a lightweight library providing a
+repository of available XYZ services offering raster basemap tiles. The
+repository is provided via Python API and as a compressed JSON file.")
+ (license license:bsd-3)))
+
(define-public jube
(package
;; This is a command-line tool, so no "python-" prefix.