summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-19 16:18:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-19 16:18:40 +0300
commit1e3046810af92d7a659a942bac1f7ec572bfc1b0 (patch)
tree984cbc2bd10015fe150adb6206c6bb1ba6cda3b1
parent77db24ff5ba50c1169642a849211d558668487aa (diff)
downloadguix-patches-1e3046810af92d7a659a942bac1f7ec572bfc1b0.tar
guix-patches-1e3046810af92d7a659a942bac1f7ec572bfc1b0.tar.gz
gnu: python-numpy: Skip 2 more tests on riscv64-linux.
* gnu/packages/python-xyz.scm (python-numpy)[arguments]: Adjust custom 'check phase to skip two more tests when building for riscv64-linux.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 723980420f..f19f0ed285 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5457,7 +5457,14 @@ include_dirs = ~:*~a/include~%" #$(this-package-input "openblas"))))))
;; These tests may fail on 32-bit systems (see:
;; https://github.com/numpy/numpy/issues/18387).
"not test_float_remainder_overflow "
- "and not test_pareto"))))))))
+ "and not test_pareto"
+ ;; These tests seem to fail on machines without
+ ;; an FPU is still under investigation upstream.
+ ;; https://github.com/numpy/numpy/issues/20635
+ #$@(if (target-riscv64?)
+ `(" and not test_float"
+ " and not test_fpclass")
+ '())))))))))
(native-inputs
(list python-cython
python-hypothesis-next