summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 18:03:13 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:16 +0100
commit013ce20502d2e8921381f19b9170dcefce29efa4 (patch)
treef586270480f7b0268f6cc6ca3cd8873466a915d8
parent5f7559efd49ca22fd8fc849f0ca10b1dd6c787a9 (diff)
downloadguix-patches-013ce20502d2e8921381f19b9170dcefce29efa4.tar
guix-patches-013ce20502d2e8921381f19b9170dcefce29efa4.tar.gz
gnu: python-isort: Do not depend on 'git'.
* gnu/packages/python-xyz.scm (python-isort)[arguments]: Disable test that uses git. [native-inputs]: Remove GIT-MINIMAL.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2b37a4d560..bda5692a50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18503,10 +18503,10 @@ multitouch applications.")
(setenv "PATH" (string-append (getenv "PATH") ":" bin)))
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "tests/unit/"
+ "-k" "not test_gitignore" ;requires git
"--ignore=tests/unit/test_deprecated_finders.py")))))))
(native-inputs
- `(("git" ,git-minimal)
- ("python-black" ,python-black)
+ `(("python-black" ,python-black)
("python-colorama" ,python-colorama)
("python-hypothesmith" ,python-hypothesmith)
("python-libcst" ,python-libcst-minimal)