summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 16:04:02 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commitdb7a344427637795b08728f4d5cdd6857682826d (patch)
tree762a60f6bfa17808d0d7d83633e02aef24ef9243
parent159a70167883b0b4d5237b7ef3493b54356f362e (diff)
downloadguix-patches-db7a344427637795b08728f4d5cdd6857682826d.tar
guix-patches-db7a344427637795b08728f4d5cdd6857682826d.tar.gz
gnu: Add bppsuite.
* gnu/packages/bioinformatics.scm (bppsuite): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 78347331dc..4450580199 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -52,12 +52,14 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages logging)
#:use-module (gnu packages machine-learning)
+ #:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
@@ -73,6 +75,7 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages tbb)
#:use-module (gnu packages tex)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -659,6 +662,45 @@ analysis, phylogenetics, molecular evolution and population genetics. This
library provides sequence-related modules.")
(license license:cecill-c))))
+(define-public bppsuite
+ ;; The last release was in 2014 and the recommended way to install from source
+ ;; is to clone the git repository, so we do this.
+ ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
+ (let ((commit "c516147f57aa50961121cd505bed52cd7603698b"))
+ (package
+ (name "bppsuite")
+ (version (string-append "2.2.0-1." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://biopp.univ-montp2.fr/git/bppsuite")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1y87pxvw0jxjizhq2dr9g2r91md45k1p9ih2sl1yy1y3p934l2kb"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:tests? #f)) ; There are no tests.
+ (native-inputs
+ `(("groff" ,groff)
+ ("man-db" ,man-db)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("bpp-core" ,bpp-core)
+ ("bpp-seq" ,bpp-seq)
+ ("bpp-phyl" ,bpp-phyl)
+ ("bpp-phyl" ,bpp-popgen)
+ ("gcc" ,gcc-5)))
+ (home-page "http://biopp.univ-montp2.fr")
+ (synopsis "Bioinformatics tools written with the Bio++ libraries")
+ (description
+ "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+analysis, phylogenetics, molecular evolution and population genetics. This
+package provides command line tools using the Bio++ library.")
+ (license license:cecill-c))))
+
(define-public blast+
(package
(name "blast+")