summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-15 17:57:00 -0400
committerLeo Famulari <leo@famulari.name>2017-04-17 13:57:01 -0400
commit2f4a58b512972975257d664e54fbc28e8a0c72fe (patch)
treece3ed8dfb9e067adcf2ecb7c7a025bce51064947
parent4ca077d5729ba172c641fe19a27db8a1977c7be0 (diff)
downloadguix-patches-2f4a58b512972975257d664e54fbc28e8a0c72fe.tar
guix-patches-2f4a58b512972975257d664e54fbc28e8a0c72fe.tar.gz
gnu: Add libmnl.
* gnu/packages/linux.scm (libmnl): New variable.
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e1ae84e3a7..4e1aa0b143 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3711,3 +3711,25 @@ and more on DMI-capable x86 or EFI (IA-64) systems and on some PowerPC
machines (PowerMac G4 is known to work).")
(home-page "https://www.ezix.org/project/wiki/HardwareLiSter")
(license license:gpl2+)))
+
+(define-public libmnl
+ (package
+ (name "libmnl")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.netfilter.org/projects/libmnl/files/"
+ "libmnl-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "108zampspaalv44zn0ar9h386dlfixpd149bnxa5hsi8kxlqj7qp"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.netfilter.org/projects/libmnl/")
+ (synopsis "Netlink utility library")
+ (description "Libmnl is a minimalistic user-space library oriented to
+Netlink developers. There are a lot of common tasks in parsing, validating,
+constructing of both the Netlink header and TLVs that are repetitive and easy to
+get wrong. This library aims to provide simple helpers that allows you to
+re-use code and to avoid re-inventing the wheel.")
+ (license license:lgpl2.1+)))