summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:26 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:38 -0400
commit22414177cdca7c4967a454a1c68caab57e3f88ba (patch)
treea899a05a1fdaee9505f99b66752f29eca6205dc7
parent7ad2bd50f81348e18ac7d6eb084c9a9cb7827f72 (diff)
downloadguix-patches-22414177cdca7c4967a454a1c68caab57e3f88ba.tar
guix-patches-22414177cdca7c4967a454a1c68caab57e3f88ba.tar.gz
gnu: Add perl-encode-detect.
* gnu/packages/perl.scm (perl-encode-detect): Add variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 17a596f72c..aef92f4b79 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7023,3 +7023,27 @@ interface to File::Find::Object.")
(description "Test::TrailingSpace tests for trailing spaces
in Perl source files.")
(license x11)))
+
+(define-public perl-encode-detect
+ (package
+ (name "perl-encode-detect")
+ (version "1.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JG/JGMYERS/Encode-Detect-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1wdv9ffgs4xyfh5dnh09dqkmmlbf5m1hxgdgb3qy6v6vlwx8jkc3"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "http://search.cpan.org/dist/Encode-Detect")
+ (synopsis
+ "Perl Encode::Encoding subclass that detects the encoding of data")
+ (description "Encode::Detect detects the encoding of data for Perl.")
+ (license mpl1.1)))