summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2022-06-17 10:37:28 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-17 15:31:33 +0200
commit37d5bd0b3158a8cb2995d340172c8105b9065885 (patch)
treef27aebe9f4e87826da24b475cdf4a29154f2e9dc
parentdf5e07c16d2d4e72423f0e8c6b5b53c7020bc77a (diff)
downloadguix-patches-37d5bd0b3158a8cb2995d340172c8105b9065885.tar
guix-patches-37d5bd0b3158a8cb2995d340172c8105b9065885.tar.gz
gnu: Add texlive-inriafonts.
* gnu/packages/tex.scm (texlive-inriafonts): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 28c2250d81..9442de6e74 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10768,6 +10768,36 @@ variants), German, Italian, Portuguese and Spanish documents are provided. This
package was originally provided as part of the author's datetime package, but is
now distributed separately.")))
+(define-public texlive-inriafonts
+ (package
+ (inherit (simple-texlive-package
+ "texlive-inriafonts"
+ (list "doc/fonts/inriafonts/"
+ "fonts/enc/dvips/inriafonts/"
+ "fonts/map/dvips/inriafonts/"
+ "fonts/opentype/public/inriafonts/"
+ "fonts/tfm/public/inriafonts/"
+ "fonts/truetype/public/inriafonts/"
+ "fonts/type1/public/inriafonts/"
+ "fonts/vf/public/inriafonts/"
+ "tex/latex/inriafonts/")
+ (base32
+ "0ngbpr4pl7r82jmdhiksp32qvbvggf2nawwqq0pkb7cffp95ya49")
+ #:trivial? #t))
+ (propagated-inputs (list texlive-ly1)) ;requires LY1 font encoding
+ (home-page "https://ctan.org/fonts/inriafonts")
+ (synopsis "Inria fonts with LaTeX support")
+ (description
+ "Inria is a free font designed by Black[Foundry] for Inria, a French research
+institute. It comes as Serif and Sans Serif, each with three weights and
+matching italics. Using these fonts with XeLaTeX and LuaLaTeX is easy using
+the fontspec package; we refer to the documentation of fontspec for more
+information. The present package provides a way of using them with LaTeX and
+pdfLaTeX: it provides two style files, @file{InriaSerif.sty} and
+@file{InriaSans.sty}, together with the PostScript version of the fonts and
+their associated files. These were created using autoinst.")
+ (license (list license:lppl license:silofl1.1))))
+
(define-public bibtool
(package
(name "bibtool")