summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-18 10:28:05 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-18 13:15:19 +0200
commitfcb23bf406f168a8a205b27200ab8fc8ead1f6c9 (patch)
tree70fcc8e8d7fdc623a9af9fcb86d0a34a8a4adb1a
parentf25033d9ea2f98f804c4cdea118406c69915bc8a (diff)
downloadguix-patches-fcb23bf406f168a8a205b27200ab8fc8ead1f6c9.tar
guix-patches-fcb23bf406f168a8a205b27200ab8fc8ead1f6c9.tar.gz
gnu: ocamlformat: Update to 0.22.4.
* gnu/packages/ocaml.scm (ocamlformat): Update to 0.22.4.
-rw-r--r--gnu/packages/ocaml.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2a45364b53..70cb29f8e3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7996,7 +7996,7 @@ defined in OCaml 4.12.0.")
(define-public ocamlformat
(package
(name "ocamlformat")
- (version "0.21.0")
+ (version "0.22.4")
(source
(origin
(method git-fetch)
@@ -8006,12 +8006,16 @@ defined in OCaml 4.12.0.")
(file-name (git-file-name name version))
(sha256
(base32
- "10vy102a0isd8cg94y61pm4qfgy74d6003dw0qn0bdmbd19r5071"))))
+ "171lq3vx4y8xj4by5zy93isx8nhg6ysxg1hxmkqkq16fdaiz8mnc"))))
(build-system dune-build-system)
(arguments
'(#:package "ocamlformat"
#:phases
(modify-phases %standard-phases
+ ;; Tests related to other packages
+ (add-after 'unpack 'remove-unrelated-tests
+ (lambda _
+ (delete-file-recursively "test/rpc")))
(add-after 'unpack 'fix-test-format
(lambda _
(substitute* "test/cli/repl_file_errors.t/run.t"