summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
commitf89822cd25cefbbc24138d48f6585a6df0f6a5a1 (patch)
treef826a129f5e5d740d06d295c1c032acf7f069b32
parente1076e934666193a0e68883c8de21bad45b44cdc (diff)
downloadguix-patches-f89822cd25cefbbc24138d48f6585a6df0f6a5a1.tar
guix-patches-f89822cd25cefbbc24138d48f6585a6df0f6a5a1.tar.gz
gnu: btrfs-progs: Update to 5.18.1.
* gnu/packages/linux.scm (btrfs-progs): Update to 5.18.1. [native-inputs]: Remove asciidoc, python, xmlto, libxml2, and docbook-xsl. Add python-sphinx.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ae2ba25fc7..e80ca436b6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -160,6 +160,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages groff)
#:use-module (gnu packages selinux)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (guix platform)
#:use-module (guix build-system cmake)
@@ -5574,7 +5575,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "5.15.1")
+ (version "5.18.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -5582,7 +5583,7 @@ and copy/paste text in the console and in xterm.")
"btrfs-progs-v" version ".tar.xz"))
(sha256
(base32
- "085rg9p7kifhh8kjyyhs38y86srwk820s6v07min5gb177rzhc32"))))
+ "0mbj3j2fpjds9i9gm8kk8a20yjacc562ibd1v9a96bpmrxfag63f"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; static versions of the binaries in "out"
@@ -5627,12 +5628,8 @@ and copy/paste text in the console and in xterm.")
("zstd" ,zstd "lib")
("zstd:static" ,zstd "static")))
(native-inputs `(("pkg-config" ,pkg-config)
- ("asciidoc" ,asciidoc)
- ("python" ,python)
- ("xmlto" ,xmlto)
;; For building documentation.
- ("libxml2" ,libxml2)
- ("docbook-xsl" ,docbook-xsl)
+ ("python-sphinx" ,python-sphinx)
;; For tests.
("acl" ,acl)
("which" ,which)