summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2021-10-13 19:01:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-18 10:51:12 +0200
commiteb5df275ce74f18994bd60d05f295fa2c5c6ce89 (patch)
treeea65a58a389a7e36063af4dd2fcd4d7bed2d85e7
parent3154b582567539d8d607344fbd03a3d8456f66cb (diff)
downloadguix-patches-eb5df275ce74f18994bd60d05f295fa2c5c6ce89.tar
guix-patches-eb5df275ce74f18994bd60d05f295fa2c5c6ce89.tar.gz
gnu: Add r-gghalves.
* gnu/packages/cran.scm (r-gghalves): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b326332bf6..96dca393e6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33395,6 +33395,30 @@ facets. It also allows multiple colour, fill scales per plot and hosts a
smaller collection of stats, geoms and axis guides.")
(license license:expat)))
+(define-public r-gghalves
+ (package
+ (name "r-gghalves")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gghalves" version))
+ (sha256
+ (base32
+ "1lj4c38fzxwg8gy57ymf00lqjdplb7v2a0lnd262c1d5cavqiws4"))))
+ (properties `((upstream-name . "gghalves")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2 r-gtable))
+ (native-inputs
+ (list r-knitr))
+ (home-page "https://github.com/erocoar/gghalves")
+ (synopsis "Compose half-half plots using your favourite geoms")
+ (description "This package provides a @code{ggplot2} extension for easy
+plotting of half-half geom combinations. Think half boxplot and half
+jitterplot, or half violinplot and half dotplot.")
+ (license license:expat)))
+
(define-public r-zoeppritz
(package
(name "r-zoeppritz")