summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-06-16 21:53:56 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-17 23:39:32 +0200
commite56f2cab6094334cd25f384f537bca26455baa8a (patch)
treea487fb49569e5c303144575a745b3e240c4f198d
parentc3afbd05bf541b31b122e6093ff10eabf6a47926 (diff)
downloadguix-patches-e56f2cab6094334cd25f384f537bca26455baa8a.tar
guix-patches-e56f2cab6094334cd25f384f537bca26455baa8a.tar.gz
gnu: Add guile-tap.
* gnu/packages/guile-xyz.scm (guile-tap): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c6f73a38e9..ff44f6c9de 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2021, 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,6 +84,7 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages haskell-xyz) ;pandoc
#:use-module (gnu packages hurd)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -5019,3 +5021,43 @@ consists of a set of Guile modules providing some of Clojure's functionality
in two different guises.")
;; Dual license: LGPLv2.1+ or EPLv1.0+ at the user's option.
(license (list license:lgpl2.1+ license:epl1.0)))))
+
+(define-public guile-tap
+ (package
+ (name "guile-tap")
+ (version "0.4.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ft/guile-tap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04ip5cbvsjjcicsri813f4711yh7db6fvc2px4788rl8p1iqvi6x"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("PREFIX = /usr/local") (string-append "PREFIX="
+ #$output)))))
+ (replace 'build
+ (lambda _
+ (invoke "make")
+ (invoke "make" "-C" "doc" "man")
+ (invoke "make" "install")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test")))))))
+ (native-inputs (list guile-3.0 pandoc))
+ (home-page "https://github.com/ft/guile-tap")
+ (synopsis "Guile test framework that emits TAP output")
+ (description
+ "guile-tap is a library for GNU Guile that implements a framework for
+specifying test cases that emit output that adheres to the Test Anything
+Protocol (TAP). It comes with an experimental harness (tap-harness).")
+ (license license:bsd-2)))