summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:01 +0200
commit9cc2fe90e8d243679ba138fb56232e0d468b7942 (patch)
tree38d63f8dda1e1509fd190ad426f626a8aa7edf17
parent6ea3bb6a542a11fe3ddb92ee91c90a5eaea32144 (diff)
downloadguix-patches-9cc2fe90e8d243679ba138fb56232e0d468b7942.tar
guix-patches-9cc2fe90e8d243679ba138fb56232e0d468b7942.tar.gz
gnu: rng-tools: Update to 6.15.
* gnu/packages/linux.scm (rng-tools): Update to 6.15. [arguments]: Add a 'disable-failing-test phase.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6e26cd3b2a..98738f1fae 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6341,7 +6341,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(package
(name "rng-tools")
(home-page "https://github.com/nhorman/rng-tools")
- (version "6.14")
+ (version "6.15")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page)
@@ -6349,7 +6349,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(file-name (git-file-name name version))
(sha256
(base32
- "1hrbm4y7fbzkg5j2f7vpj19ri2ff2lp77al17fhi4mv0bvdfjd9m"))))
+ "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
(build-system gnu-build-system)
(arguments
`(;; Disable support for various hardware entropy sources as they need
@@ -6357,7 +6357,15 @@ The collection contains a set of bandwidth and latency benchmark such as:
;; increase closure size.
#:configure-flags '("--without-nistbeacon"
"--without-pkcs11"
- "--without-rtlsdr")))
+ "--without-rtlsdr")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This test requires a hwrng, rdrand, or tpm device.
+ ;; Worse, it appears to fail if that isn't sufficiently random.
+ (("\\brngtestjitter\\.sh\\b") " ")))))))
(native-inputs
(list autoconf automake pkg-config))
(inputs