summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-17 10:25:48 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-17 18:49:05 +0200
commit82cff40a9c5733bdf7eb5e5d6089c39c0011643b (patch)
tree690f0f3ab1312e5b92e66cce6a116a632581a26c
parent8e19e3a3331a8251789aea5a977ec4e7b5dc5c25 (diff)
downloadguix-patches-82cff40a9c5733bdf7eb5e5d6089c39c0011643b.tar
guix-patches-82cff40a9c5733bdf7eb5e5d6089c39c0011643b.tar.gz
gnu: Add python-pefile.
* gnu/packages/python-xyz.scm (python-pefile): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 285863df07..723980420f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17964,6 +17964,28 @@ JSON) codec.")
Record Format (DWARF).")
(license license:public-domain)))
+(define-public python-pefile
+ (package
+ (name "python-pefile")
+ (version "2022.5.30")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/erocarrera/pefile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qj90a0s2gd5hn2zggypqc1077inid5dcl1fp5973b04kf2b9z8a"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-future))
+ (home-page "https://github.com/erocarrera/pefile")
+ (synopsis "Portable Executable (PE) file parser")
+ (description "This python library provides interfaces for parsing and
+working with Portable Executable (PE) files. It makes to most information
+from the header, as well as section details and data available.")
+ (license license:expat)))
+
(define-public python-pyev
(package
(name "python-pyev")