summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-18 13:02:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-18 13:15:21 +0200
commit7b615e3e6c68a33a315446b8158d8574855d9c8f (patch)
treefaf401d5e71de4e4ae189560dbebf4ef3b4f1c02
parent4a94cfbe4dcf7311ab66c5d94a171752d2ba725e (diff)
downloadguix-patches-7b615e3e6c68a33a315446b8158d8574855d9c8f.tar
guix-patches-7b615e3e6c68a33a315446b8158d8574855d9c8f.tar.gz
gnu: Add ocaml-piqi.
* gnu/packages/ocaml.scm (ocaml4.07-piqi): Rename to... (ocaml-piqi): ...this. Use latest ocaml.
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e5067c4c35..3cfbd69924 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3956,9 +3956,9 @@ and 4 (random based) according to RFC 4122.")
(description "OCamlgraph is a generic graph library for OCaml.")
(license license:lgpl2.1)))
-(define-public ocaml4.07-piqi
+(define-public ocaml-piqi
(package
- (name "ocaml4.07-piqi")
+ (name "ocaml-piqi")
(version "0.7.7")
(source (origin
(method git-fetch)
@@ -3982,15 +3982,13 @@ and 4 (random based) according to RFC 4122.")
(lambda _
(for-each make-file-writable (find-files "."))
#t))
- (delete 'configure))
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib))
+ (delete 'configure))))
(native-inputs
(list which protobuf)) ; for tests
(propagated-inputs
- `(("ocaml-num" ,(package-with-ocaml4.07 ocaml-num))
- ("ocaml-piqilib" ,(package-with-ocaml4.07 ocaml-piqilib))
- ("ocaml-stdlib-shims" ,(package-with-ocaml4.07 ocaml-stdlib-shims))))
+ `(("ocaml-num" ,ocaml-num)
+ ("ocaml-piqilib" ,ocaml-piqilib)
+ ("ocaml-stdlib-shims" ,ocaml-stdlib-shims)))
(home-page "https://github.com/alavrik/piqi-ocaml")
(synopsis "Protocol serialization system for OCaml")
(description "Piqi is a multi-format data serialization system for OCaml.
@@ -4027,7 +4025,7 @@ XML and Protocol Buffers formats.")
("ocaml-frontc" ,(package-with-ocaml4.07 ocaml-frontc))
("ocaml-graph" ,(package-with-ocaml4.07 ocaml-graph))
("ocaml-ocurl" ,(package-with-ocaml4.07 ocaml-ocurl))
- ("ocaml-piqi" ,ocaml4.07-piqi)
+ ("ocaml-piqi" ,(package-with-ocaml4.07 ocaml-piqi))
("ocaml-ppx-jane" ,ocaml4.07-ppx-jane)
("ocaml-utop" ,ocaml4.07-utop)
("ocaml-uuidm" ,(package-with-ocaml4.07 ocaml-uuidm))