summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
commit2c975efe836e83333d4decb87577a6ff9857c4a5 (patch)
treebb49320ca5a628cd4302d0f30bab745a119c4863
parent9305d176094c5ed4dbc4bec6a31f80164f097c0c (diff)
downloadguix-patches-2c975efe836e83333d4decb87577a6ff9857c4a5.tar
guix-patches-2c975efe836e83333d4decb87577a6ff9857c4a5.tar.gz
gnu: duktape: Use G-expressions.
* gnu/packages/javascript.scm (duktape)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/javascript.scm39
1 files changed, 22 insertions, 17 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 5598341e5c..1d571a1c72 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -828,22 +828,27 @@ Javascript and a small built-in standard library with C library wrappers.")
"19szwxzvl2g65fw95ggvb8h0ma5bd9vvnnccn59hwnc4dida1x4n"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests.
- #:make-flags (list "-f" "Makefile.sharedlibrary"
- (string-append "INSTALL_PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- ;; At least another major GNU/Linux distribution carries their own
- ;; .pc file with this package.
- (add-after 'install 'install-pkg-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (pkg-config-dir (string-append out "/lib/pkgconfig")))
- (mkdir-p pkg-config-dir)
- (with-output-to-file (string-append pkg-config-dir "/duktape.pc")
- (lambda _
- (format #t "prefix=~@*~a~@
+ (list #:tests? #f ; No tests.
+ #:make-flags
+ #~(list "-f" "Makefile.sharedlibrary"
+ (string-append "INSTALL_PREFIX="
+ ;; XXX Replace with #$output on core-updates.
+ #$(if (%current-target-system)
+ #~#$output
+ #~%output)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ ;; At least another major GNU/Linux distribution carries their own
+ ;; .pc file with this package.
+ (add-after 'install 'install-pkg-config
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (pkg-config-dir (string-append out "/lib/pkgconfig")))
+ (mkdir-p pkg-config-dir)
+ (with-output-to-file (string-append pkg-config-dir "/duktape.pc")
+ (lambda _
+ (format #t "prefix=~@*~a~@
libdir=${prefix}/lib~@
includedir=${prefix}/include~@
@@ -852,7 +857,7 @@ Javascript and a small built-in standard library with C library wrappers.")
Version: ~a~@
Libs: -L${libdir} -lduktape~@
Cflags: -I${includedir}~%"
- out ,version)))))))))
+ out #$version)))))))))
(home-page "https://duktape.org/")
(synopsis "Small embeddable Javascript engine")
(description "Duktape is an embeddable Javascript engine, with a focus on