summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-18 12:38:56 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-18 13:15:20 +0200
commit0133c000c91a209a6af08af94d512229f20f65de (patch)
treec279ff7f3e1b825319f08bda74ad5d5dd2e59f71
parent3cd53fc08f68e7a47a2ff4b993ab53645b65f386 (diff)
downloadguix-patches-0133c000c91a209a6af08af94d512229f20f65de.tar
guix-patches-0133c000c91a209a6af08af94d512229f20f65de.tar.gz
gnu: ocaml-sexplib0: Update to 0.15.1.
* gnu/packages/ocaml.scm (ocaml-sexplib0): Update to 0.15.1.
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 808b1a3664..c17055b29d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5024,11 +5024,17 @@ exclusion algorithms are typical examples of such systems.")
(define-public ocaml-sexplib0
(package
(name "ocaml-sexplib0")
- (version "0.15.0")
+ (version "0.15.1")
(home-page "https://github.com/janestreet/sexplib0")
- (source
- (janestreet-origin "sexplib0" version
- "1fpg991n578m11r0ki4als4c76s3sp703b4khivx40v48402qill"))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05m93g4m4jhj1v8pazg3s2ydcfymr3h4476yjhdca5fm4sn35bg8"))))
(build-system dune-build-system)
(arguments `(#:tests? #f)) ;no tests
(properties `((ocaml4.07-variant . ,(delay ocaml4.07-sexplib0))))