summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 18:31:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:58:09 +0200
commitffc18b87f9d34ef44a977af8c83d103ae5c56050 (patch)
tree8886ac250fb9cb8d5e4b9a79d585af41f4325b30
parent1e6d64c2dc42c699678534eb2a0e9cfc6a09ce61 (diff)
downloadguix-patches-ffc18b87f9d34ef44a977af8c83d103ae5c56050.tar
guix-patches-ffc18b87f9d34ef44a977af8c83d103ae5c56050.tar.gz
gnu: Add rebar3-git-vsn.
* gnu/packages/erlang.scm (rebar3-git-vsn): New variable.
-rw-r--r--gnu/packages/erlang.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 76e386baf2..5b93902f61 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages tls)
#:use-module (gnu packages wxwidgets))
@@ -647,3 +648,34 @@ of locations (git, hg, etc).")
(description "This plugin provides support for handling non-OTP
applications as a dependent libraries.")
(license license:expat)))
+
+(define-public rebar3-git-vsn
+ (package
+ (name "rebar3-git-vsn")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "rebar3_git_vsn" version))
+ (sha256
+ (base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
+ (build-system rebar-build-system)
+ (inputs
+ (list git-minimal/fixed))
+ (arguments
+ `(;; Running the tests require binary artifact (tar-file containing
+ ;; samples git repos) TODO: remove these from the source
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((git (assoc-ref inputs "git-minimal")))
+ (substitute* "src/rebar3_git_vsn.erl"
+ (("rebar_utils:sh\\(\"git " _)
+ (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
+ (home-page "https://github.com/soranoba/rebar3_git_vsn")
+ (synopsis "Rebar3 plugin for generating the version from git")
+ (description "This plugin adds support for generating the version from
+a git checkout.")
+ (license license:expat)))