summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-16 15:17:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-16 15:20:59 +0200
commitfbe5707b73a5c2e8432ebac2e28b80ad19d89c97 (patch)
tree18095b15411868975a0a055ae8995a3829eceed4
parentd62dbedd6d3a64e26c386b1c7091ef9eebd65da9 (diff)
downloadguix-patches-fbe5707b73a5c2e8432ebac2e28b80ad19d89c97.tar
guix-patches-fbe5707b73a5c2e8432ebac2e28b80ad19d89c97.tar.gz
gnu: Add python-ctxcore.
* gnu/packages/bioinformatics.scm (python-ctxcore): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87df6c3515..6dde6b6976 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -111,6 +111,7 @@
#:use-module (gnu packages jupyter)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages logging)
#:use-module (gnu packages lsof)
#:use-module (gnu packages machine-learning)
@@ -13380,6 +13381,49 @@ information... The package can also be used to extract data from @code{.loom}
files.")
(license license:expat))))
+(define-public python-ctxcore
+ (package
+ (name "python-ctxcore")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aertslab/ctxcore")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16nlj7z8pirgjad7vlgm7226b3hpw4a7n967vyfg26dsf5n8k70d"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pretend-version
+ ;; The version string is usually derived via setuptools-scm, but
+ ;; it doesn't work without the .git directory.
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
+ (propagated-inputs
+ (list python-cytoolz
+ python-numba
+ python-frozendict
+ python-numpy
+ python-pandas
+ python-pyyaml
+ python-pyarrow-0.16
+ python-tqdm))
+ (native-inputs
+ (list python-pytest
+ python-setuptools-scm))
+ (home-page "https://github.com/aertslab/ctxcore")
+ (synopsis "Core functions for pycisTarget and the SCENIC tool suite")
+ (description
+ "ctxcore is part of the SCENIC suite of tools. It provides core functions for
+pycisTarget and SCENIC.")
+ (license license:gpl3+)))
+
(define-public vbz-compression
(package
(name "vbz-compression")