summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-16 15:19:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-16 15:20:59 +0200
commitf700223c3bb7e80104c7c011edcd09479145bb26 (patch)
treea48b51a3c85f8135f6958d514d78c32cbc657f41
parent3535d8dc5ae3116d8c3bedf0d5c920b19ba41cc5 (diff)
downloadguix-patches-f700223c3bb7e80104c7c011edcd09479145bb26.tar
guix-patches-f700223c3bb7e80104c7c011edcd09479145bb26.tar.gz
gnu: Add pyscenic.
* gnu/packages/bioinformatics.scm (pyscenic): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e6b14069ec..75973b0dd8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13457,6 +13457,69 @@ pycisTarget and SCENIC.")
tree-based ensemble regressors.")
(license license:bsd-3)))
+(define-public pyscenic
+ (package
+ (name "pyscenic")
+ (version "0.11.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aertslab/pySCENIC")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pbmmr1zdb1vbbs6wx357s59d13pna6x03wq8blj6ckjws8bbq73"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'check 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp")))
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-v"))))))
+ (propagated-inputs
+ (list python-ctxcore
+ python-cytoolz
+ python-multiprocessing-on-dill
+ python-llvmlite
+ python-numba
+ python-attrs
+ python-frozendict
+ python-numpy
+ python-pandas
+ python-cloudpickle
+ python-dask
+ python-distributed
+ python-arboreto
+ python-boltons
+ python-setuptools
+ python-pyyaml
+ python-tqdm
+ python-interlap
+ python-umap-learn
+ python-loompy
+ python-networkx
+ python-scipy
+ python-fsspec
+ python-requests
+ python-aiohttp
+ python-scikit-learn))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://scenic.aertslab.org/")
+ (synopsis "Single-Cell regulatory network inference and clustering")
+ (description
+ "pySCENIC is a Python implementation of the SCENIC pipeline (Single-Cell
+rEgulatory Network Inference and Clustering) which enables biologists to infer
+transcription factors, gene regulatory networks and cell types from
+single-cell RNA-seq data.")
+ (license license:gpl3+)))
+
(define-public vbz-compression
(package
(name "vbz-compression")