summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 16:22:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:48 +0200
commitd723e8d94bc0e3f41285fa5cd64cd953d6a31d17 (patch)
tree9464d6b356deec10a7ba370103418446183bfb09
parente0376bc8a4acb721300b4b898460a44e1e04b7dc (diff)
downloadguix-patches-d723e8d94bc0e3f41285fa5cd64cd953d6a31d17.tar
guix-patches-d723e8d94bc0e3f41285fa5cd64cd953d6a31d17.tar.gz
gnu: Add erlang-jsone.
* gnu/packages/erlang.scm (erlang-jsone): New variable.
-rw-r--r--gnu/packages/erlang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 1ce61e5d7d..4df57673c9 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -403,6 +403,30 @@ arguments using the GNU getopt syntax.")
specifications.")
(license license:asl2.0)))
+(define-public erlang-jsone
+ (package
+ (name "erlang-jsone")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "jsone" version))
+ (sha256
+ (base32 "1gaxiw76syjp3s9rygskm32y9799b917q752rw8bxj3bxq93g8x3"))))
+ (build-system rebar-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-covertool
+ ;; no need to generate a coverage report
+ (lambda _
+ (substitute* "rebar.config"
+ (("\\{project_plugins, \\[covertool\\]\\}\\." _) "")))))))
+ (home-page "https://github.com/sile/jsone/")
+ (synopsis "Erlang JSON Library")
+ (description "An Erlang library for encoding and decoding JSON data.")
+ (license license:expat)))
+
(define-public erlang-parse-trans
(package
(name "erlang-parse-trans")