summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 07:07:14 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:21 -0400
commitca81e057b2b6c6b7b3dc8598c84d81d6bbb16512 (patch)
treed8c32abf27dfa0b56a8aad471dc8866d32207fd2
parenta1b965f8827a93a9a7de1472fa9c137dfce03fe1 (diff)
downloadguix-patches-ca81e057b2b6c6b7b3dc8598c84d81d6bbb16512.tar
guix-patches-ca81e057b2b6c6b7b3dc8598c84d81d6bbb16512.tar.gz
gnu: cairomm: Enable documentation.
* gnu/packages/gtk.scm (cairomm)[outputs]: New output "doc". [arguments]<#:configure-flags>[-Dbuild-documentation]: New flag. <#:phases>['move-doc]: New phase. [native-inputs]: Add doxygen, graphviz, perl and libxslt. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 82d59ed60b..4c3514c2a9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1274,15 +1274,32 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(base32
"1ya4y7qa000cjawqwswbqv26y5icfkmhs5iiiil4dxgrqn91923y"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:configure-flags
(list
- "-Dboost-shared=true")))
+ "-Dbuild-documentation=true"
+ "-Dboost-shared=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))
(native-inputs
`(("boost" ,boost)
+ ("dot" ,graphviz)
+ ("doxygen" ,doxygen)
("mm-common" ,mm-common)
- ("pkg-config" ,pkg-config)))
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
`(("libsigc++" ,libsigc++)
("freetype" ,freetype)