summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:46:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-16 09:25:55 +0200
commit9ee6d9cb176e09b07c64cf1a2bf30c0d2d3c0ade (patch)
tree152aedeca4bc1f9b2305b4708865577316a8c138
parent2950ef2fffa6b00ba35e2e8e3fb5074d812166f1 (diff)
downloadguix-patches-9ee6d9cb176e09b07c64cf1a2bf30c0d2d3c0ade.tar
guix-patches-9ee6d9cb176e09b07c64cf1a2bf30c0d2d3c0ade.tar.gz
gnu: Add python-pytest-httpx.
* gnu/packages/python-check.scm (python-pytest-httpx): New variable.
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index cb22972d10..8302e2e09f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2293,3 +2293,34 @@ documentation by parsing them from their source and evaluating the
parsed examples as part of your normal test run. Integration is
provided for the main Python test runners.")
(license license:expat)))
+
+(define-public python-pytest-httpx
+ (package
+ (name "python-pytest-httpx")
+ (version "0.21.0")
+ (source
+ (origin
+ ;; pypi package doesn't include the tests
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Colin-b/pytest_httpx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12mcy1f5d5cq3rqrqgi2ar0qvzw62ibys17hw6dsdfd0j2syck4r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "PYTHONPATH" (getcwd))
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-httpx))
+ (native-inputs (list python-pytest python-pytest-asyncio))
+ (home-page "https://colin-b.github.io/pytest_httpx/")
+ (synopsis "Pytest plugin to mock httpx")
+ (description "This package provides a pytest fixture to mock httpx
+requests to be replied to with user provided responses.")
+ (license license:expat)))