summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 19:03:51 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:58:10 +0200
commit9cccf6490d98bd40ea1eb9e84ecf4a2b32614107 (patch)
tree8bc106770cb2c7ba3e41fdb6ee1010f9674294ab
parentffc18b87f9d34ef44a977af8c83d103ae5c56050 (diff)
downloadguix-patches-9cccf6490d98bd40ea1eb9e84ecf4a2b32614107.tar
guix-patches-9cccf6490d98bd40ea1eb9e84ecf4a2b32614107.tar.gz
gnu: Add rebar3-proper.
* gnu/packages/erlang.scm (rebar3-proper): New variable.
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 5b93902f61..53b58aec60 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -679,3 +679,20 @@ applications as a dependent libraries.")
(description "This plugin adds support for generating the version from
a git checkout.")
(license license:expat)))
+
+(define-public rebar3-proper
+ (package
+ (name "rebar3-proper")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "rebar3_proper" version))
+ (sha256
+ (base32 "1f174fb6h2071wr7qbw9aqqvnglzsjlylmyi8215fhrmi38w94b6"))))
+ (build-system rebar-build-system)
+ (home-page "https://github.com/ferd/rebar3_proper")
+ (synopsis "Rebar3 PropEr plugin")
+ (description "This plugin allows running PropEr test suites from within
+rebar3.")
+ (license license:bsd-3)))