summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-14 16:03:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-12 15:18:57 +0200
commit801f1a7c2993e44384487241c8b44e870c05a09a (patch)
treecd929a7241797e26e3e1ad21031a2c9f031bc06a
parent8226771a337df104e3c6a7cb123a968e1226a619 (diff)
downloadguix-patches-801f1a7c2993e44384487241c8b44e870c05a09a.tar
guix-patches-801f1a7c2993e44384487241c8b44e870c05a09a.tar.gz
gnu: Add librsvg-bootstrap.
* gnu/packages/gnome.scm (librsvg-bootstrap): New variable.
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 596745f613..404c0e4d7d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3632,6 +3632,34 @@ diagrams.")
(home-page "https://wiki.gnome.org/LibRsvg")
(license license:lgpl2.1+)))
+;; This copy of librsvg uses the bundled rust libraries. It is useful for
+;; packages which have too many dependencies to be rebuilt as frequently
+;; as the rust inputs are updated.
+;; TODO: Remove this package and use packaged rust libraries!
+(define-public librsvg-bootstrap
+ (package
+ (inherit librsvg)
+ (name "librsvg")
+ (version "2.50.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/librsvg/"
+ (version-major+minor version) "/"
+ "librsvg-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1g3f8byg5w08fx1bka12mmpl59v6a4q2p827w6m2la6mijq63yzz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "vendor" "\\.a$"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments librsvg)
+ ((#:vendor-dir _ "vendor") "vendor")
+ ((#:cargo-inputs _) '())
+ ((#:cargo-development-inputs _) '())))
+ (properties '((hidden? . #t)))))
+
(define-public librsvg-2.40
;; This is the last version implemented in C.
(package