summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-11 16:25:17 +0000
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-16 09:25:55 +0200
commit7a8beb3deae0d61d242f5639d2835ce76d27b4c0 (patch)
tree3e7b4ff4933c3214450cb360c283392b82d4c1b5
parente0b6cd0947a09378338801edbeef78ab58696505 (diff)
downloadguix-patches-7a8beb3deae0d61d242f5639d2835ce76d27b4c0.tar
guix-patches-7a8beb3deae0d61d242f5639d2835ce76d27b4c0.tar.gz
gnu: python-requests-file: Update to 1.5.1.
* gnu/packages/python-xyz.scm (python-requests-file): Update to 1.5.1. [source]: Make some cosmetic changes. [arguments]<#:phases>: Override 'check phase. [home-page]: Don't break line.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e82c3b674..f9c5d909f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21612,19 +21612,24 @@ and corruption checks.")
(define-public python-requests-file
(package
(name "python-requests-file")
- (version "1.4.3")
+ (version "1.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "requests-file" version))
(sha256
- (base32
- "1yp2jaxg3v86pia0q512dg3hz6s9y5vzdivsgrba1kds05ial14g"))))
+ (base32 "13kx4k83i9zcv20h0fnmawwwdzhcmw1z97mqib1h379qsc445mq7"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "tests/test_requests_file.py")))))))
(propagated-inputs
(list python-requests python-six))
- (home-page
- "https://github.com/dashea/requests-file")
+ (home-page "https://github.com/dashea/requests-file")
(synopsis "File transport adapter for Requests")
(description
"Requests-File is a transport adapter for use with the Requests Python