summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 12:20:52 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:39 -0400
commit6f779ac5d32d0cc18b4bbb853a31e5e1684afa01 (patch)
tree098b8834196c8594c03ac1a2ef891371960f2dec
parent0ba9fee14da764011e77a9ed1ff1a1bd7c337ca2 (diff)
downloadguix-patches-6f779ac5d32d0cc18b4bbb853a31e5e1684afa01.tar
guix-patches-6f779ac5d32d0cc18b4bbb853a31e5e1684afa01.tar.gz
gnu: libgsf: Enable documentation.
* gnu/packages/gnome.scm (libgsf) [outputs]: New output "doc". [arguments]<#:configure-flags>[--with-html-dir]: New flag. [native-inputs]: Add docbook-xml. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 101d87c96f..c715b4391b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3275,7 +3275,7 @@ XML/CSS rendering engine.")
(base32
"0kbpp9ksl7977xiga37sk1gdw1r039v6zviqznl7alvvg39yp26i"))))
(build-system glib-or-gtk-build-system)
- (outputs '("out" "bin"))
+ (outputs '("out" "bin" "doc"))
(arguments
`(#:configure-flags
(list
@@ -3293,10 +3293,24 @@ XML/CSS rendering engine.")
,(version-major
(package-version gobject-introspection))
".0")
+ (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html")
"--with-zlib"
- "--with-bz2")))
+ "--with-bz2")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "doc"
+ (substitute* "gsf-docs.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.5/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t)))))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("docbook-xml" ,docbook-xml)
+ ("gettext" ,gettext-minimal)
("gobject-introspection" ,gobject-introspection)
("perl" ,perl)
("perl-xml-parser" ,perl-xml-parser)