summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-16 15:15:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-16 15:20:59 +0200
commit62c51214725e59fc216b9d13b87629de13c30ebe (patch)
treee7f3ff156cb256dae3f8f9b5431f7d7a07257bbd
parente4dbf938ea72132c1c6082f239aa844d7acb584f (diff)
downloadguix-patches-62c51214725e59fc216b9d13b87629de13c30ebe.tar
guix-patches-62c51214725e59fc216b9d13b87629de13c30ebe.tar.gz
gnu: Add python-interlap.
* gnu/packages/python-xyz.scm (python-interlap): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d66a753a3d..0cd811c9bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23602,6 +23602,23 @@ several convenience Python scripts, including \"classic\" hex2bin and bin2hex
converters and more, those based on the library itself.")
(license license:bsd-3)))
+(define-public python-interlap
+ (package
+ (name "python-interlap")
+ (version "0.2.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "interlap" version))
+ (sha256
+ (base32
+ "1jbfh00bkrf0i5psa6n75rlgmqp5389xixa9j29w8rxhah6g7r1i"))))
+ (build-system python-build-system)
+ (home-page "https://brentp.github.io/interlap")
+ (synopsis "Fast, simple interval overlap testing")
+ (description "InterLap does fast interval overlap testing with a simple Python data
+structure.")
+ (license license:expat)))
+
(define-public python-pykwalify
(package
(name "python-pykwalify")