summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-16 15:18:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-16 15:20:59 +0200
commit3535d8dc5ae3116d8c3bedf0d5c920b19ba41cc5 (patch)
tree99cd15c7e82111c0212778c14fb90e44972fdb07
parentfbe5707b73a5c2e8432ebac2e28b80ad19d89c97 (diff)
downloadguix-patches-3535d8dc5ae3116d8c3bedf0d5c920b19ba41cc5.tar
guix-patches-3535d8dc5ae3116d8c3bedf0d5c920b19ba41cc5.tar.gz
gnu: Add python-arboreto.
* gnu/packages/bioinformatics.scm (python-arboreto): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6dde6b6976..e6b14069ec 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13424,6 +13424,39 @@ files.")
pycisTarget and SCENIC.")
(license license:gpl3+)))
+(define-public python-arboreto
+ (package
+ (name "python-arboreto")
+ (version "0.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aertslab/arboreto")
+ (commit "2f475dca08f47a60acc2beb8dd897e77b7495ca4")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l0im8ay7l2d24f7vaha454vsaha9s36bfqhbijg3b8ir8apsd7l"))))
+ (build-system python-build-system)
+ ;; Lots of tests fail because python-distributed fails to start the
+ ;; "Nanny" process.
+ (arguments '(#:tests? #false))
+ (propagated-inputs
+ (list python-bokeh
+ python-dask
+ python-distributed
+ python-numpy
+ python-pandas
+ python-scikit-learn
+ python-scipy
+ python-tornado-6))
+ (home-page "https://github.com/aertslab/arboreto")
+ (synopsis "Gene regulatory network inference using tree-based ensemble regressors")
+ (description
+ "This package implements scalable gene regulatory network inference using
+tree-based ensemble regressors.")
+ (license license:bsd-3)))
+
(define-public vbz-compression
(package
(name "vbz-compression")