summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 12:08:10 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:39 -0400
commit3094309b9db81b79e8264f3c2dcc466d81deba9a (patch)
treedb4d25bc329dcec6a7924f1ecffda069cac58bcf
parentd61767ae572db6eaa3381854a648c89d420b820d (diff)
downloadguix-patches-3094309b9db81b79e8264f3c2dcc466d81deba9a.tar
guix-patches-3094309b9db81b79e8264f3c2dcc466d81deba9a.tar.gz
gnu: libgsf: Enable missing features.
* gnu/packages/gnome.scm (libgsf) [arguments]<#:configure-flag>[--enable-introspection]: New flag. [--with-gir-dir=]: New flag. [--with-typelib-dir=]: New flag. [--with-zlib]: New flag. [--with-bz2]: New flag. [native-inputs]: Add gobject-introspection. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f110d786f..48f8b09ba7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3277,9 +3277,27 @@ XML/CSS rendering engine.")
(build-system glib-or-gtk-build-system)
(outputs '("out" "bin"))
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags
+ (list
+ "--disable-static"
+ "--enable-introspection"
+ (string-append "--with-gir-dir="
+ (assoc-ref %outputs "out")
+ "/share/gir-"
+ ,(version-major
+ (package-version gobject-introspection))
+ ".0")
+ (string-append "--with-typelib-dir="
+ (assoc-ref %outputs "out")
+ "/lib/girepository-"
+ ,(version-major
+ (package-version gobject-introspection))
+ ".0")
+ "--with-zlib"
+ "--with-bz2")))
(native-inputs
`(("gettext" ,gettext-minimal)
+ ("gobject-introspection" ,gobject-introspection)
("perl" ,perl)
("perl-xml-parser" ,perl-xml-parser)
("pkg-config" ,pkg-config)))