summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-16 15:16:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-16 15:20:59 +0200
commit21e9e67c77ba9b9aac7957e0a3befcfcc508a386 (patch)
tree648c4db905abd4aed6e189fa73be18b14beeb61e
parent62c51214725e59fc216b9d13b87629de13c30ebe (diff)
downloadguix-patches-21e9e67c77ba9b9aac7957e0a3befcfcc508a386.tar
guix-patches-21e9e67c77ba9b9aac7957e0a3befcfcc508a386.tar.gz
gnu: Add python-multiprocessing-on-dill.
* gnu/packages/python-xyz.scm (python-multiprocessing-on-dill): New variable.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0cd811c9bb..e6bd8c4832 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22191,6 +22191,34 @@ which supports the spawning of processes using the API of the standard
library's @code{threading} module.")
(license license:bsd-3)))
+(define-public python-multiprocessing-on-dill
+ (package
+ (name "python-multiprocessing-on-dill")
+ (version "3.5.0a4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiprocessing_on_dill" version))
+ (sha256
+ (base32
+ "1rs5a3hx1fcpfsxxkl5kx6g06c82wqjqgdqyny5l1ggl1wq0rmfn"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-dill))
+ (native-inputs (list python-check-manifest python-pytest python-wheel))
+ (home-page "https://github.com/sixty-north/multiprocessing_on_dill")
+ (synopsis "Multiprocessing using dill instead of pickle")
+ (description
+ "This package provides a friendly fork of multiprocessing which uses dill
+instead of pickle.")
+ (license license:psfl)))
+
(define-public python-toolrack
(package
(name "python-toolrack")