summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-06 10:50:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:58:08 +0200
commit0018a4788b644cde094757020e044a7370036740 (patch)
tree16ec44511f5ea50fb7c13f8c8562d0c5dcfdabdd
parenteb8c8ba11f9a65b07b956d287e9bcba2b14f5223 (diff)
downloadguix-patches-0018a4788b644cde094757020e044a7370036740.tar
guix-patches-0018a4788b644cde094757020e044a7370036740.tar.gz
gnu: Add erlang-covertool.
* gnu/packages/erlang.scm (erlang-covertool): New variable.
-rw-r--r--gnu/packages/erlang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 1531a11b29..f48b84c476 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -279,6 +279,27 @@ Mozilla's canonical set.")
printing extending the io:format syntax to add colours.")
(license license:expat)))
+(define-public erlang-covertool
+ (package
+ (name "erlang-covertool")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "covertool" version))
+ (sha256
+ (base32 "1p0c1n3nl4063xwi1sv176l1x68xqf07qwvj444a5z888fx6i5aw"))))
+ (build-system rebar-build-system)
+ (home-page "https://github.com/covertool/covertool")
+ (synopsis "Convert code-coverage data generated by @code{cover} into
+Cobertura XML reports")
+ (description "This package provides a build tool and plugin to convert
+exported Erlang @code{cover} data sets into Cobertura XML reports, which can
+then be feed to the Jenkins Cobertura plug-in.
+
+On @emph{hex.pm}, this plugin was previously called @code{rebar_covertool}.")
+ (license license:bsd-2)))
+
(define-public erlang-cth-readable
(package
(name "erlang-cth-readable")