summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-05-14 11:59:07 +0300
committerLudovic Courtès <ludo@gnu.org>2022-05-21 00:15:09 +0200
commitb29358f1988c0b1a5dc456115f2e753c69198088 (patch)
treed231c14c1995219b288ebb23051e13fd0ea30617
parent20b498b7dbeb7756a41d4d565b66813a6d1eba9a (diff)
downloadguix-patches-b29358f1988c0b1a5dc456115f2e753c69198088.tar
guix-patches-b29358f1988c0b1a5dc456115f2e753c69198088.tar.gz
gnu: Add python-murmurhash3.
* gnu/packages/python-xyz.scm (python-murmurhash3): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b8fd857fd6..1802867d17 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,6 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31383,3 +31384,37 @@ object, which can be useful if you want to force your objects into a table.")
"The @code{deep-merge} Python library provides a toolset to deeply merge
nested data structures in Python like lists and dictionaries.")
(license license:expat)))
+
+(define-public python-murmurhash3
+ (package
+ (name "python-murmurhash3")
+ (version "2.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "murmurhash3" version))
+ (sha256
+ (base32
+ "1gdzys1212dx70byz07ipknbw1awbqskh6aznlkm85js8b8qfczm"))))
+ (build-system python-build-system)
+ (native-inputs (list python-cython python-pytest))
+ (inputs (list python))
+ (arguments
+ (list #:modules
+ '((ice-9 ftw) (ice-9 match)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-source-file-times-to-1980
+ (lambda _
+ (let ((circa-1980 (* 10 366 24 60 60)))
+ (ftw "."
+ (lambda (file stat flag)
+ (utime file circa-1980 circa-1980) #t))))))))
+ (home-page "https://github.com/veegee/mmh3")
+ (synopsis "Python wrapper for MurmurHash (MurmurHash3)")
+ (description
+ "@code{murmurhash3} is a Python library for MurmurHash (MurmurHash3), a set
+of fast and robust hash functions. This library is a Python extension module
+written in C.")
+ (license license:public-domain)))